600123讲解通达信财神到主图指标公式 无未来

2020-04-26 23:38:46 投稿人 : 股海游勇

股海游勇讲解通达信财神到主图指标公式 无未来 北京证券交易所,常铝股份股票,002349精华制药,这份解读适用于大多数投资者!

600123讲解通达信财神到主图指标公式 无未来

以下是通达信财神到主图指标公式 无未来(无源码的请下载附件导入)

{财神到匘===无未来函数}
N:=(27,1,100);N1:=(7,1,100);N2:=(19,1,100);
HH:=HHV(H,10);
LL:=LLV(L,10);
AA:=SMA(C,13,2);
DRAWTEXT(ISLASTBAR=1 AND AA>REF(AA,1) AND REF(AA,1)<REF(AA,2) AND REF(AA,2)<REF(AA,3),HH,'激进买入'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND AA>REF(AA,1) AND REF(AA,1)>REF(AA,2),HH,'激进持股'),COLOR0066FF;
DRAWTEXT(ISLASTBAR=1 AND AA<REF(AA,1) AND REF(AA,1)>REF(AA,2),HH,'激进卖出'),COLORGREEN;
A1:=MA(C,13);
ZX:=REF(A1,13/2+1);
DRAWTEXT(ISLASTBAR=1 AND CROSS(C,ZX),LL,'稳健买入'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND C>ZX AND REF(C,1)>REF(ZX,1),LL,'稳健持股'),COLOR0066FF;
DRAWTEXT(ISLASTBAR=1 AND C<ZX AND REF(C,1)>REF(ZX,1),LL,'稳健卖'),COLORGREEN;
VAR1111:=FORCAST(CLOSE,5);
VAR1:=1;
平衡线:=(EMA(EMA(EMA(HIGH,3),3),1) * VAR1);
VAR2:=(平衡线 * 0.85);
临界线:WMA(CLOSE,10),LINETHICK2,COLORRED;
VAR1A:=POW((CLOSE - 临界线),1);
VAR2A:=MA(VAR1A,3);
VAR3A:=SQRT(VAR2A);
支撑线:=(临界线 - (1.96 * VAR3A));
IF((临界线 < REF(临界线,1)),临界线,DRAWNULL),LINETHICK2,COLORFFFFFF;
VAR1Z:=(((CLOSE - OPEN) / OPEN) * 100);
VAR2Z:=REF(CLOSE,1);
VAR3Z:=((SMA(MAX((CLOSE - VAR2Z),0),6,1) / SMA(ABS((CLOSE - VAR2Z)),6,1)) * 100);
VAR4Z:=(COUNT((VAR3Z < 20),20) >= 1);
DRAWTEXT(((VAR1Z > 9) AND VAR4Z),LOW,'★屠龙'),LINETHICK4,COLORFFFFDD;
JJJ:=(((CLOSE + HIGH) + LOW) / 3);
AAA:=EMA(JJJ,3);
BBA:=REF(AAA,1);
持股:DRAWICON((AAA > BBA),L*0.99,11);
VAR3:=REF(CLOSE,1);
VAR4:=REF(CLOSE,2);
VAR5:=REF(CLOSE,3);
VAR6:=REF(CLOSE,9);
VAR7:=HHV(CLOSE,9);
VAR8:=LLV(CLOSE,9);
VARC:=(((VAR3 = VAR8) AND (CLOSE >= VAR4)) OR ((((VAR4 = VAR8) AND (VAR3 <= VAR5)) AND (VAR4 < VAR6)) AND (CLOSE >= VAR3)));
黄色买入:STICKLINE(VARC,(VAR3 * 0.94),(VAR4 * 0.94),25,16),COLORFFFFFF;
VAR1B:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR2B:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR3B:=(MA(CLOSE,N) + (2 * STD(CLOSE,N)));
DRAWICON(CROSS(VAR2B,VAR3B),(HIGH * 1.035),15);
DRAWTEXT(CROSS(VAR2B,VAR3B),(HIGH * 1.02),'卖出'),COLORFF00EE;
VAR4B:=REF(CLOSE,1);
VAR5B:=((SMA(MAX((CLOSE - VAR4B),0),N1,1) / SMA(ABS((CLOSE - VAR4B)),N1,1)) * 100);
VAR6B:=CROSS(N2,VAR5B);
VAR7B:=FILTER(VAR6B,4);
A7:=((((2 * CLOSE) + HIGH) + LOW) / 4);
VAR10:=LLV(LOW,34);
VAR11A:=HHV(HIGH,34);
SK:=EMA((((A7 - VAR1B) / (VAR2B - VAR1B)) * 100),7);
SD:=EMA(((0.667 * REF(SK,1)) + (0.333 * SK)),5);
DRAWTEXT(IF((((((COUNT((CLOSE < REF(CLOSE,1)),8) / 8) > (6 / 10)) AND (VOL >= (1.5 * MA(VOL,5)))) AND COUNT((SK >= SD),3)) AND (REF(LOW,1) = LLV(LOW,120))),1,0),LOW,'●买进'),COLOR99FFEE;
DRAWTEXT(IF((((((((((COUNT((CLOSE < REF(CLOSE,1)),13) / 13) > (6 / 10)) AND COUNT((SK > SD),6)) AND (REF(LOW,5) = LLV(LOW,120))) AND REF((CLOSE >= OPEN),4)) AND REF((CLOSE > OPEN),3)) AND REF((CLOSE > OPEN),2)) AND REF((OPEN > CLOSE),1)) AND (OPEN > REF(CLOSE,1))),1,0),LOW,'●买进2'),COLORFFFFDD;
VAR12:=(MA(CLOSE,80) - (MA(CLOSE,10) / 3));
DRAWTEXT(IF(((((CLOSE < VAR12) AND ((VOL / 240) > (MA(VOL,5) / 240))) AND (CLOSE > (REF(CLOSE,1) * 1.08))) AND (CLOSE < (MA(CLOSE,13) * 1.3))),1,0),LOW,'●抄底'),COLORFFFFDD;
VAR11:=(((((2 * CLOSE) + OPEN) + HIGH) + LOW) / 5);
M8:=VOL;
主力:=(SUM((VAR11 * M8),3) / SUM(M8,3));
散户:=主力;
M1:=LLV(散户,5);
M5:=(SUM((VAR11 * M8),1) / SUM(M8,1));
M13:=(SUM((VAR11 * M8),5) / SUM(M8,5));
M21:=(SUM((VAR11 * M8),13) / SUM(M8,13));
Y:=(SUM((VAR11 * M8),21) / SUM(M8,21));
U1:=M5;
U3:=M13;
XX1:=M21;
C5:=((U3 > 散户) AND (散户 > XX1));
C8:=IF((C5 > 0),LLV(U3,5),HHV(散户,5));
C13:=IF((C5 > 0),LLV(散户,8),HHV(散户,5));
VAR1118:=IF((C5 > 0),LLV(XX1,13),HHV(散户,5));
M1A:=LLV(散户,20);
DRAWTEXT((M1A = REF(M1A,1)),M1A,'┬'),LINETHICK5,COLORCC33FF;
DRAWTEXT(((REF(M1A,1) < REF(M1A,2)) AND (M1A = REF(M1A,1))),L*0.97,'★'),COLORFFEEDD;
{STICKLINE((CLOSE < OPEN),HIGH,LOW,1,0),COLOR8800;
STICKLINE((CLOSE < OPEN),HIGH,LOW,0,0),COLORFF00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,8,0),COLOR8800;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,7,0),COLOR9900;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,6,0),COLORAA00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,5,0),COLORBB00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),COLORCC00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,3,0),COLORDD00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,2,0),COLOREE00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,1,0),COLORFF00;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,1,0),COLORFF;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,0,0),COLOREEFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),COLORFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),COLOR22FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),COLOR44FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),COLOR66FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),COLOR88FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),COLORAAFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),COLORCCFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),COLOREEFF;}
VAR22:=((LLV(LOW,3) = LLV(LOW,3)) AND (CLOSE >= (OPEN * 1.04)));
VAR333:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
VAR44:=(VAR22 AND VAR333);
VAR55:=BARSLAST(VAR333);
VAR66:=BARSLAST(VAR44);
VAR77:=IF((VAR66 > 0),(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100),0);
VAR88:=SUM(VAR77,1);
VAR93:=IF((VAR55 > 3),(0 - 2),0);
DRAWICON(((REF(VAR93,1) = (0 - 2)) AND (VAR93 = 0)),LOW*0.96,1);
DRAWICON(((REF(VAR93,1) = (0 - 2)) AND (VAR93 = 0)),LOW*0.98,23);
{====}
XA:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
YA:=EMA(CLOSE,10);
DRAWTEXT(CROSS(YA,XA),(LOW * 0.95),'←安全C级'),COLORRED;
VAR1C:=LLV(LOW,21);
VAR2C:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1C) / (VAR2C - VAR1C)) * 100),5);
AK:=EMA((((CLOSE - VAR1C) / (VAR2C - VAR1C)) * 50),13);
DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3C:=LLV(LOW,55);
VAR4C:=HHV(HIGH,34);
VAR5C:=EMA((((CLOSE - VAR3C) / (VAR4C - VAR3C)) * 100),3);
VAR6C:=((AK + VAR5C) / 2);
VAR7C:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8C:=EMA(VAR6C,5);
BB:=EMA(((0.667 * REF(VAR8C,1)) + (0.333 * VAR8C)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT((CD = 0.6),(LOW * 0.95),'←安全A级'),COLORGREEN;
DRAWTEXT((AB = 1),(LOW * 0.97),'←安全 B 级'),COLOR33CC99,COLORYELLOW;
{====}
压力:MA(REF(HHV(C,30),1),2),COLORGREEN;
支撑:MA(REF(LLV(C,30),1),2),COLORRED;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORFF6600;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.7,0 ),COLORFF7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.6,0 ),COLORFF9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.5,0 ),COLORFFBB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.4,0 ),COLORFFCC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.3,0 ),COLORFFDD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORFFEE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORFFFF00;
{立体柱子:红色}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.8,0) ,COLOR000033;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.3,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000DD;
VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF (C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2) =HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3) =HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
红持:VAR9Q,COLOR0000FF,LINETHICK0;
{立体柱子:红色}
STICKLINE(VAR9Q,C,(O+C)/2,2.8,0),COLOR000044;
STICKLINE(VAR9Q,C,(O+C)/2,2.7,0),COLOR000055;
STICKLINE(VAR9Q,C,(O+C)/2,2.6,0),COLOR000066;
STICKLINE(VAR9Q,C,(O+C)/2,2.5,0),COLOR000077;
STICKLINE(VAR9Q,C,(O+C)/2,2.4,0),COLOR000099;
STICKLINE(VAR9Q,C,(O+C)/2,2.3,0),COLOR0000BB;
STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR0000DD;
STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000FF;
VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
粉变:VARAQ,COLORFF99FF,LINETHICK0;
STICKLINE(VARAQ,C,(O+C)/2,2.8,0),COLORFF11FF;
STICKLINE(VARAQ,C,(O+C)/2,2.7,0),COLORFF22FF;
STICKLINE(VARAQ,C,(O+C)/2,2.6,0),COLORFF33FF;
STICKLINE(VARAQ,C,(O+C)/2,2.5,0),COLORFF55FF;
STICKLINE(VARAQ,C,(O+C)/2,2.4,0),COLORFF77FF;
STICKLINE(VARAQ,C,(O+C)/2,2.3,0),COLORFF99FF;
STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFFBBFF;
STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFFDDFF;
VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
银灰跌:VARBQ,COLOR888888,LINETHICK0;
{立体柱子:银色}
STICKLINE(VARBQ,C,(O+C)/2,2.8,0),COLOR333333;
STICKLINE(VARBQ,C,(O+C)/2,2.7,0),COLOR444444;
STICKLINE(VARBQ,C,(O+C)/2,2.6,0),COLOR555555;
STICKLINE(VARBQ,C,(O+C)/2,2.5,0),COLOR777777;
STICKLINE(VARBQ,C,(O+C)/2,2.4,0),COLOR999999;
STICKLINE(VARBQ,C,(O+C)/2,2.3,0),COLORBBBBBB;
STICKLINE(VARBQ,C,(O+C)/2,2,0),COLORDDDDDD;
STICKLINE(VARBQ,C,(O+C)/2,1,0),COLORFFFFFF;
VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
绿买:VARCQ,COLOR00FF00,LINETHICK0;
{立体柱子:绿色}
STICKLINE(VARCQ,O,(O+C)/2,2.8,0),COLOR004400;
STICKLINE(VARCQ,O,(O+C)/2,2.6,0),COLOR005500;
STICKLINE(VARCQ,O,(O+C)/2,2.5,0),COLOR007700;
STICKLINE(VARCQ,O,(O+C)/2,2.4,0),COLOR009900;
STICKLINE(VARCQ,O,(O+C)/2,2.3,0),COLOR00BB00;
STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR00DD00;
STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR00FF00;
VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF (C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
蓝抛:VARDQ,COLORFF9900,LINETHICK0;
{立体柱子:深蓝色}
STICKLINE(VARDQ,O,(O+C)/2,2.8,0),COLORFF1100;
STICKLINE(VARDQ,O,(O+C)/2,2.7,0),COLORFF2200;
STICKLINE(VARDQ,O,(O+C)/2,2.6,0),COLORFF3300;
STICKLINE(VARDQ,O,(O+C)/2,2.5,0),COLORFF5500;
STICKLINE(VARDQ,O,(O+C)/2,2.4,0),COLORFF7700;
STICKLINE(VARDQ,O,(O+C)/2,2.3,0),COLORFF9900;
STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFFBB00;
STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFFDD00;
{立体柱子:金色}
ZDF:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
STICKLINE(ZDF>9.8,OPEN,CLOSE,2.8,0),COLOR004444;
STICKLINE(ZDF>9.8,OPEN,CLOSE,2.7,0),COLOR005555;
STICKLINE(ZDF>9.8,OPEN,CLOSE,2.6,0),COLOR006666;
STICKLINE(ZDF>9.8,OPEN,CLOSE,2.5,0),COLOR007777;
STICKLINE(ZDF>9.8,OPEN,CLOSE,2.4,0),COLOR009999;
STICKLINE(ZDF>9.8,OPEN,CLOSE,2.3,0),COLOR00BBBB;
STICKLINE(ZDF>9.8,OPEN,CLOSE,2,0),COLOR00DDDD;
STICKLINE(ZDF>9.8,OPEN,CLOSE,1,0),COLOR00FFFF;
Z:=(CLOSE > REF(CLOSE,1));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT((XL3 > 0),(LOW - 0.2),'←绝对底部');
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5);
VAR5S:=HHV(HIGH,4);
散户C:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
XX:=EMA(0.667*REF(散户C,1)+0.333*散户C,2)*VAR3S;
DRAWTEXT(CROSS(散户C,XX) AND 散户C<30,L-0.05,'←吸'),COLORRED;
VAR1R:=LLV(LOW,2)=LLV(LOW,16) AND CLOSE>=OPEN*1.04;
VAR2R:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR3R:=VAR1R AND VAR2R;
DRAWTEXT(VAR3R,LOW,'-→逢低买入 '),COLORFFFFEE;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.99),'←---大胆搏 '),COLORYELLOW;
SHORT1:=12;
LONG1:=26;
M:=9;
DIFF:=EMA(CLOSE,SHORT1)-EMA(CLOSE,LONG1);
DEA:=EMA(DIFF,M);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWTEXT(低位金叉,L*0.92,'*低位金叉'),COLORF00FF0;
SHORT:=12;
LONG:=26;
A1C:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(A1C=2,21)=1;
DRAWTEXT(二次金叉,L*0.90,'*二次金叉'),COLORYELLOW;
QC:=REF(CLOSE,1);
RSV:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
YX:=((CLOSE>QC) AND C>O);
D1:=REF(D,1);
DRAWTEXT((((D1<30) AND CROSS(K,D)) AND YX),(LOW * 0.96),'*短买!'),COLORYELLOW;
VAR4A:=EMA(CLOSE,3);
DRAWTEXT(COUNT(REF(VAR4A,1)<REF(VAR4A,2),5)=5 AND VAR4A>REF(VAR4A,1),L*0.96,'出拳'),COLORRED;
DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;
DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;
DRAWTEXT(CROSS(DA-DB,0),L*0.98,'★B'),COLORMAGENTA;
AA1:=MA(C,5);
BB1C:=MA(C,15);
AF:=CROSS(AA1,BB1C);
DRAWTEXT(AF,LLV(L,4),'止损线'),COLORYELLOW;



前期,大家对市场比较迷茫,看不清方向的时候,达哥曾经说过,这个时候最稳当的,无疑是蓝筹白马股,这也是重点关注的方向。

以上就是小编为您带来的关于“600123讲解通达信财神到主图指标公式 无未来”全部内容,更多内容请关注炒股指标公式网!

相关文章